Results 1 to 4 of 4

Thread: Observation of failing kingdom orders

  1. #1
    Silver Member Contributor Level 5
    Join Date
    Jan 2014
    Posts
    107
    Rep Power
    9

    Observation of failing kingdom orders

    An issue I have with several things, especially wall upgrades is that the client is accepting a single mouse click at times as a multiple click. When building walls, this results in the wasting of coins by upgrading a wall segment twice when the player is not ready to do so. Sure, eventually they will want that next upgrade, but they are not ready then. They wanted a single upgrade on several other segments with those funds.

    Well, in watching a kingdom order fail, I believe I observed the same phenomena: I clicked submit. Only clicked it once, and it should have immediately been disabled. My credits increased, goods and coins started getting paid off, and then suddenly the "cannot submit at this time" pop-up briefly appeared, the credits, coins and goods were removed, and my client and the server were now out of synch. I had to refresh. Queues are trashed. I need to waste troops to get back to where I was, goods lost, troops missing, etc.

    It would appear that the client tried to send the submit twice, not legal, and the validation routines could not reconcile. If click processing it corrected a big chunk of the kingdom order errors, complaints about wall builds, complaints about getting 100 of a troop type when I player said to build 1, and so on would vanish. This is especially true with double-clicking should not even be a possibility.

  2. #2
    Spartacus
    Guest
    The Kingdom Orders malfunction has been a haunted pain. We’re still trying to fix it.

  3. #3
    Quote Originally Posted by Spartacus View Post
    The Kingdom Orders malfunction has been a haunted pain. We’re still trying to fix it.
    I have not gotten an order to go through in a week, every time it says, cannot complete order at this time and takes troops

  4. #4

    The Troops stay at rally

    Ok, well, happens it to me too, i was thinking the problem was, when i summit an order before one of those clocks going down to zero, but now reading this, as Spartacus, says, is a problem that is trying to fixing, for a while try at least to return the troops that "were summited" if they can be effective.
    I tried again if i can summit King Orders, so i took the risk, and just built up the troops to complete the King order, I sent it, and effectively, just pop up, my coins up, my goodies up, my credits up, for a second, then back to original numbers, my troops gone (in the summit window) so I back to my town, and I found all my Army there, so when the system can't give you the rewards, they don't take your troops away. That is good. But still need to fix that, I tried 1 a day is good.
    Last edited by <cFc>Balthazar; 03-21-2014 at 01:42 PM. Reason: My troops are there in my Rally

  5. #5
    Silver Member Contributor Level 5
    Join Date
    Jan 2014
    Posts
    107
    Rep Power
    9
    Programmers should know, this was not a random observations. This may not be the only cause, but I am giving you one of the causes of the problem. Your code is taking a single click and trying to submit the order twice. This is a violation, and you hack prevention is catching it as such, but completely trashing the queues when attempting to recover. It happens with many other things as well, but is most obvious when trying to update troop queues or doing orders.

  6. #6
    Dawnseeker
    Guest
    Thanks for the reports guys.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •