Results 1 to 9 of 9

Thread: I want my money back

  1. #1
    Iron Member Contributor Level 2
    Join Date
    Mar 2015
    Posts
    20
    Rep Power
    3

    I want my money back

    Over a month and the game won't start on iOS 7 . Change the specifications of the game with iphone 5 or above and send us our money back. I bought an annual card . What I will do with that ?

  2. #2
    Diamond Member Contributor Level 8
    Join Date
    Jun 2015
    Posts
    630
    Rep Power
    24
    im not sure anyone else is still having an issue?

  3. #3
    New Comers
    Join Date
    May 2017
    Posts
    3
    Rep Power
    1
    I'm defnately still having the same issues since March 14th. And they still haven't told us what the deal is. Disappointing

  4. #4
    Diamond Member Contributor Level 8
    Join Date
    Jun 2015
    Posts
    630
    Rep Power
    24
    you can file a complaint for fraud with apple, they should be able to take it from there, if in fact it is because ucool wont support previous versions of iOS. If its just you or your phone or something, then you have no recourse

  5. #5
    Diamond Member Contributor Level 9 [GY] Nader's Avatar
    Join Date
    Nov 2015
    Location
    Beirut, Lebanon
    Posts
    847
    Rep Power
    32
    ucool does not issue a refund for whatever reason. Like foloron said, if your complaint is legit check with apple for a refund.
    Server 27 - 30. Guild Leader of Miracle.
    VIP 14, 15 R4, 18 R3, 28 R2, 40 max trained heroes.
    Guild miracle is looking for a strong and active players to help in GT.
    Minimum requirement: 35 max trained heroes, 25+ heroes >= R3.
    Line ID: naderzarif

  6. #6
    Bronze Member Contributor Level 3
    Join Date
    Jun 2015
    Posts
    44
    Rep Power
    4
    Most game platform no longer support older version ios

  7. #7
    Diamond Member Contributor Level 8
    Join Date
    Jun 2015
    Posts
    630
    Rep Power
    24
    Quote Originally Posted by Ollieafa View Post
    Most game platform no longer support older version ios
    that version isnt that old, 3 years

  8. #8
    Bronze Member Contributor Level 3
    Join Date
    Jun 2015
    Posts
    44
    Rep Power
    4
    Any lower than ios 10 is old, they bout to launch ios 11,

  9. #9
    Iron Member Contributor Level 2
    Join Date
    Mar 2015
    Posts
    20
    Rep Power
    3
    I don't care if my iOS is old . That's not the point .
    The official site says until today that minimum specifications is iOS 7.0 .
    If I pay something in advance for a whole year it's not my problem if today they can't fix the game.
    Simple...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •